邓超
ToQuery
关于 Project facet Java version 1.7 is not supported. 的解决办法
2014-07-28 11:16:49   阅读725次

在移植eclipse项目时,如果遇到

“Project facet Java version 1.7 is not supported.”


项目中的jdk1.7不支持。说明项目是其他版本jdk编译的,在eclipse里运行时会报版本不支持。

解决办法:

法1,选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version ...          即可。



法2,在 项目的目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下;

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
<fixed facet="jst.java"/>
<fixed facet="jst.web"/>
<installed facet="jst.web" version="2.4"/>
<installed facet="jst.java" version="6.0"/>
</faceted-project>

修改 <installed facet="jst.java" version="6.0"/> 为 <installed facet="jst.java" version="5.0"/> 即可。




-----------------------------------------------------
转载请注明来源此处
原地址:#

-----网友评论----
暂无评论
-----发表评论----
微网聚博客乐园 ©2014 blog.mn886.net 鲁ICP备14012923号   网站导航